All our plugins are WooCommerce 3.0 & WordPress 4.8 compatible!

I can not see the options / settings page

Please make sure you have installed the Redux Framework Plugin. Some of our plugins like the store locator also require the free Meta Box plugin.

WPML Compatibility

Our plugins are not tested with WPML. So we can not guarantee, that they will work with WPML.

To learn more how to setup Redux Framework with WPML see this link https://docs.reduxframework.com/core/advanced/wpml-integration/

How do I update a plugin

  1. deactivate the old plugin
  2. delete the old plugin
  3. install the new one
  4. activate it

Settings will not be affected as they are saved in your database.

Hooks / Filters / Actions

With the new versions you will be able to remove actions or create hooks.

As an example here is how to remove the icons in the WooCommerce Print Products plugin:

1. Way

remove_action( 'init', array( $WooCommerce_Print_Products->plugin_public, 'initWooCommerce_Print_Products' ) );

2. Way:

add_action( 'init', 'remove_print_icons' ); 

function remove_print_icons() { 
      global $WooCommerce_Print_Products; 

      remove_action( 'woocommerce_product_meta_end', 
      array( $WooCommerce_Print_Products->plugin_public, 
      'show_print_links' ), 90 ); 
}

The first way is recommended here.

Error: ... expects parameter 2 to be array, null given ...

Please make sure you have installed the Redux Framework Plugin. Then go into the plugin settings and save all options again.

Images in PDF displays as a red cross (https / mpdf)

Please make sure you have installed / configured the following in your Server PHP Extensions:

  1. CURL Enabled (php_curl.dll enabled)
  2. PHP.ini (allow_url_fopen = On)
  3. GD Library installed

If images still do not display you can solve the issue by the following ways:

Quick and Dirty:

Add the following to the mpdf.php file on line 12954 -> function: file_get_contents_by_curl()

curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false);

Source: https://stackoverflow.com/questions/5657382/curl-php-restful-service-always-returning-false

Better:

The better solution is to manually add only the certificate(s) or CA(s) you want to accept

;;;;;;;;;;;;;;;;;;;;
; php.ini Options  ;
;;;;;;;;;;;;;;;;;;;;

curl.cainfo = "C:\xampp\php\extras\ssl\cacert.pem"

Source: https://stackoverflow.com/questions/24611640/curl-60-ssl-certificate-unable-to-get-local-issuer-certificate

Cannot modify header information – headers already sent by

Please make sure you have no text that is outputted before HTML tag. Please also make sure to turn off WP-Debug and try again. Also try to remove spaces, new lines, or other garbage in wp-config.php,

Blank Page / White Screen of Death

Turn on WP_DEBUG, check the error and report back to us. For a short fix please rename the last installed plugin or theme folder.

Wordpress White Screen / Blank page and no errors

If you see no error install this Plugin. Then send the logfiles to us.

Fatal error: Allowed memory size of 33554432 bytes exhausted

If you’re allowed to edit the PHP.ini file, update your memory_limit in PHP.ini by modifying the below line:

memory_limit = 256M;

If you can not access the php.ini file, try adding the following to your .htaccess file:

php_value memory_limit 256M

OR, if this also does not work, edit wp-config.php file and add the following before the comment thats all Happy Blogging.

define('WP_MEMORY_LIMIT', '256M');
If 256M is not enough, try more (like 512M).

Maximum execution time of XX seconds exceeded

If you’re allowed to edit the PHP.inifile, update your max_execution_time in PHP.ini by modifying the below line:

max_execution_time = 300 ;

Otherwise try adding the script below to your .htaccess file:

php_value max_execution_time 300
If 300 seconds is not enough, try 400 or more.

Fatal error: Cannot redeclare tgmpa()

This is a theme related error. It seems like your theme use a very old version of the TGM plugin. Please get in touch with your theme developer to fix this issue.

Or you could install the newest version yourself: http://tgmpluginactivation.com

Parse error: syntax error, unexpected end of file in ...

Please make sure you have installed the latest version of the plugin. If you are able to, we highly recommended to upgrade your PHP version to at least 5.6.

Parse error - syntax error ... on line XXX

Please report the FULL error directly with the line number to support@db-dzine.com

I found a bug / got an error

Please make a comment on CodeCanyon. We will take care asap!

Search